Home / Common Vulnerability Exposure BE-2022-0017

BE-2022-0017: SKP File Parsing Out-of-bounds Read Vulnerabilities and Stack Overflow in MicroStation and MicroStation-based applications

Bentley ID: BE-2022-0017
CVE ID: CVE-2022-42899
Severity: 7.8 (High)
CVSS v3.1: AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Publication date: 12th October 2022
Revision date: 13th October 2022 

Summary

MicroStation and MicroStation-based applications may be affected by out-of-bounds read and stack overflow vulnerabilities when opening maliciously crafted SKP files. Exploiting these vulnerabilities could lead to information disclosure and code execution.

Details

Using an affected version of MicroStation or MicroStation-based application to open a SKP file containing maliciously crafted data can force an out-of-bounds read or stack overflow. Exploitation of these vulnerabilities within the parsing of SKP files could enable an attacker to read information in the context of the current process or execute arbitrary code.

Affected Versions of Products

ProductAffected VersionFixed Version
MicroStation10.17.0.* and prior versions10.17.01.58* and more recent
Bentley View10.17.0.* and prior version10.17.01.19* and more recent

Recommended Mitigations

Bentley recommends updating to the latest versions of MicroStation and MicroStation-based applications. As a general best practice, it is also recommended to only open SKP files coming from trusted sources.

Acknowledgement

Thanks to xina1i for discovering these vulnerabilities.

Revision History

DateDescription
12th October 2022First version of the advisory
13th October 2022Adding CVE number